1987 warrior wiring and fuel problems... please help, im so new to this

Yamaha Raptor 350 & Warrior Forum

Help Support Yamaha Raptor 350 & Warrior Forum:

warrior87sambo

Well-Known Member
Joined
Jan 27, 2013
Messages
230
Reaction score
0
Location
Northern VA
this is my first post and i love this site! i am having some problems with my warrior... i picked up the bike for 100 bucks like a month ago and it apparently needed a top end rebuild (really just the exhaust valve and timing chain.) so now ive got it all shiny and hooked up but i cant for the life of me remember where the fuel line from the tank goes in. is it the the valve towards the top, or the one at the bottom? there is also a line coming out of the middle section that is about 8 inches long but doesnt connect to anything it just sticks out of the carb. when i tried to bump start it today it started pouring fuel out of the carb.

ok on to the more intimidating problem. the wiring :/. ok so the guy before me really jacked it up. there were a bunch of wires that were just electrical taped together, some that were just broken and not hooked to anything, and some that just were twisted together... the three of regulator plugs are broken off and three of the wires are broken off the regulator unit but still hooked to the plug. i did replace the starter relay. im still getting no lights, no dash lights, and the starter wont turn. but i have put a lot of time into this thing and i really wanna get it running soon. if anyone has a wiring diagram for an 87 that would be great... i really appreciate it.
 

88WarriorBoy

Well-Known Member
Joined
Jun 1, 2012
Messages
2,223
Reaction score
0
Location
Manito,Illinois
for the carb it is the fuel line on the side and the bottom line is a vent tube but id it is pouring out fuel your needles is stuck in the seat or your float hieght is off, take the carb apart and clean it real good. For the wiring if you are getting no lights, with a battery check the fuse it should be on the back of the quad located under the left rear fender on a frame tube.
 

warrior87sambo

Well-Known Member
Joined
Jan 27, 2013
Messages
230
Reaction score
0
Location
Northern VA
ok i will do that. also there are two fuse looking things with rubber boots around them, which one do you thing it is? thanks
 

88WarriorBoy

Well-Known Member
Joined
Jun 1, 2012
Messages
2,223
Reaction score
0
Location
Manito,Illinois
nope its burnt out and that is not a stock 15 amp fuse looks more like a 20- 30 amp which means that someone had a shorting out problem or they didnt have any other fuses on hand
 

warrior87sambo

Well-Known Member
Joined
Jan 27, 2013
Messages
230
Reaction score
0
Location
Northern VA
it was wrapped in tin foil too lol. so i pulled the harness off the bike and im in the process of unwrapping it. so i need a 15 amp fuse?
 

mrjim0214

Well-Known Member
Joined
Feb 19, 2012
Messages
1,034
Reaction score
0
Location
florida
ok i will do that. also there are two fuse looking things with rubber boots around them, which one do you thing it is? thanks
do the 87's have the spare fuse holder like my 95.? that may be why your seeing 2 fuse looking thingys with boots
 
Top