Hey everyone,

Yamaha Raptor 350 & Warrior Forum

Help Support Yamaha Raptor 350 & Warrior Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

littleoldguy

New Member
Joined
Jun 7, 2024
Messages
2
Reaction score
1
Location
Pueblo co
I got my first quad the other day. 97 warrior for 900. It's beat up pretty bad but it runs or it did! Idk I changed the battery to the right size one and it blew the fuse as soon as I touch the leads to the battery.

Anyway haha here is what she looks like before
 

Attachments

  • bcad6d78-5391-40c8-8844-bf914972811a.jpg
    bcad6d78-5391-40c8-8844-bf914972811a.jpg
    2.7 MB · Views: 0
  • 784f88e7-956f-4419-8245-1dfc8d865dd0.jpg
    784f88e7-956f-4419-8245-1dfc8d865dd0.jpg
    1.8 MB · Views: 0
Love that it's a before picture, implies there's something in mind for an after. Congrats on picking up a nice little project!
 
Welcome to the community! We're glad to have you join us!
 
Thanks guys um I could use soma advise on the fuse blowing issue on this if u would please. I'm getting pretty frustrated with it. Haha I'm new to small engines and electrical issues and inside will be greatly appreciated!
 
I got my first quad the other day. 97 warrior for 900. It's beat up pretty bad but it runs or it did! Idk I changed the battery to the right size one and it blew the fuse as soon as I touch the leads to the battery.

Anyway haha here is what she looks like before
You have a bad ground or something got unplugged double check all your grounds and wires
 
Do you have a reader if you do I know for a fact there’s a download manual somewhere on this site check all your neutral wires and grounds and see if you can find the manual it will help you find them
 
Do you have a reader if you do I know for a fact there’s a download manual somewhere on this site check all your neutral wires and grounds and see if you can find the manual it will help you find them
I would check and see if they have a file section here but if you need I will look in my clymers warrior Manuel tommorow and take a picture of the 97 wiring diagram and send it too you if you wanna get in touch with me on fb I'm under kayden komraus you can messenger me and I will send it too you that way or see if I can help you figure out your issue , I just replaced my whole electrical system on my warrior so now I have everything new and know the system front too back on mine now and understand it and know what any issue is with my sysytem
 

Attachments

  • 20240703_153602.jpg
    20240703_153602.jpg
    1.6 MB · Views: 0
  • 20240703_153550.jpg
    20240703_153550.jpg
    1.8 MB · Views: 0
  • Screenshot_20240704_132550_Messenger.jpg
    Screenshot_20240704_132550_Messenger.jpg
    1.3 MB · Views: 0
  • 20240622_132812.jpg
    20240622_132812.jpg
    3.6 MB · Views: 0
  • 20240615_125757.jpg
    20240615_125757.jpg
    3.6 MB · Views: 0
  • 20240615_125947.jpg
    20240615_125947.jpg
    3.3 MB · Views: 0
  • 20240615_125500.jpg
    20240615_125500.jpg
    1.7 MB · Views: 0
I got my first quad the other day. 97 warrior for 900. It's beat up pretty bad but it runs or it did! Idk I changed the battery to the right size one and it blew the fuse as soon as I touch the leads to the battery.

Anyway haha here is what she looks like before
Here's my b4 , after and the new 2.0 version
 

Attachments

  • Screenshot_20240617_172046_Gallery.jpg
    Screenshot_20240617_172046_Gallery.jpg
    905.4 KB · Views: 0
  • Screenshot_20240620_212244_Facebook.jpg
    Screenshot_20240620_212244_Facebook.jpg
    1.4 MB · Views: 0
  • 20240622_132812.jpg
    20240622_132812.jpg
    3.6 MB · Views: 0

Latest posts

Back
Top