new clutch installed on 05 350 raptor, jumps when i shift into first. explanation/clarafication

Yamaha Raptor 350 & Warrior Forum

Help Support Yamaha Raptor 350 & Warrior Forum:

Joined
Dec 18, 2021
Messages
13
Reaction score
0
Location
Texas, San Antonio area
I have finished installing a new clutch pack in my raptor. When I shift into first it jumps and stalls. I have adjusted the clutch link on the outside of the cover, spun the shaft to take out the slack in the shaft, lined up the marks on the actuator linkage and the mark on the cover. The clutch lever has about the width of a Nickle free play. The new clutch pack has been in oil for 4 -5 days. The extended soaking was due to delays in the parts being delivered. I have read that it could be the clutch disks sticking together, and it is a common occurrence. I am idling the engine as we speak to heat up the oil.
This is the first clutch I have changed, is this normal? I have checked my adjustments numerous times and I feel they are correct. I need some assurance that I have not overlooked anything. Thanks.


I found the problem, I left out the washer that goes between the clutch basket and the backplate for clutch plates. All is well.
 
Last edited:
Joined
Dec 18, 2021
Messages
13
Reaction score
0
Location
Texas, San Antonio area
Yup. I saw the waves on the sides of the slots, I remembered hearing to look for that in a class I was taking at the University of YouTube. I'm working on my 8th degree as I type. I bought a big bore kit for my Chinese Raptor clone 250. I am going huge, really huge....1,5mm huge..65.5mm to 67mm. broke 50mph and the rings with the original piston. My buddy bet me 200.00 that I could not break 50, it is a net profit 110.00 dollars after it was done. after buying the BB kit. I know he will make another bet so I am making plans. No bets to be made with the Raptor, I had to do some work on the Raptor to get it back to quality. I will upload pics of before and after. The nose was spray painted black, covering the original red, the white plastics looked khaki. I stripped the black off and wet sanded the plastics, it looks sick now.
 
Top