2004 warrior stopped running after new cylinder and piston

Yamaha Raptor 350 & Warrior Forum

Help Support Yamaha Raptor 350 & Warrior Forum:

Jrsktm250

Member
Joined
Nov 9, 2022
Messages
5
Reaction score
1
Location
Florida
So had an old warrior sitting and decided to get it running. Bought new carb, cylinder and piston kit of Amazon (I know I should have bought a name brand) Put everything back together and ran great for a week or so. After that I noticed it started to lose power and didn’t want to run after the engine got hot. Maybe 5 mins of run time. Everything else seemed totally fine. Finally I lost compression all at once. Was only getting 30 psi. I thought maybe a bad ring or something so it took it apart again and everything looking fine. Seems like the piston still has a pretty good seal when inspecting it. Not sure where to go now. I don’t want to waste more money trying to buy another cylinder kit. Could it be the valves maybe? Or is there a way to bench test this cylinder kit. What am I missing? Any help is much appreciated.
 

Jrsktm250

Member
Joined
Nov 9, 2022
Messages
5
Reaction score
1
Location
Florida
Some pics
 

Attachments

  • D3530A62-A1A7-4CA1-99D4-87A9340E0FEF.jpeg
    D3530A62-A1A7-4CA1-99D4-87A9340E0FEF.jpeg
    1.6 MB · Views: 0
  • 10DCDFB4-E0C2-4A26-88D5-5B2795DFAE05.jpeg
    10DCDFB4-E0C2-4A26-88D5-5B2795DFAE05.jpeg
    1.4 MB · Views: 0
  • EC406239-B82C-4292-AE59-22603DF23C2F.jpeg
    EC406239-B82C-4292-AE59-22603DF23C2F.jpeg
    1.4 MB · Views: 0
  • C0C9B136-3F2B-4126-A71A-E07A07245A7D.jpeg
    C0C9B136-3F2B-4126-A71A-E07A07245A7D.jpeg
    4.2 MB · Views: 0
  • A0A58069-3E52-40AF-8709-981C36FE3DC6.jpeg
    A0A58069-3E52-40AF-8709-981C36FE3DC6.jpeg
    2.2 MB · Views: 0

ag2560

Well-Known Member
Joined
Mar 14, 2010
Messages
403
Reaction score
3
From the looks of the first picture I think the valves hit the piston.
 

YFM

Administrator
Staff member
Admin
Moderator
Joined
Dec 8, 2018
Messages
209
Reaction score
15
So had an old warrior sitting and decided to get it running. Bought new carb, cylinder and piston kit of Amazon
Welcome! Great that you decided to get it running. How long has it been sitting?
 

Jrsktm250

Member
Joined
Nov 9, 2022
Messages
5
Reaction score
1
Location
Florida
I don’t see any marks. You might be seeing reflection from shop lights
After further inspection you were right. The intake valve is bent and has a gap you can see light through. I thought I set the timing right but I remember I had to choose be between one tooth or the other when putting timing chain back on. It didn’t seem to line up exactly. Any advice after I replace valves and put it back together. Thank you
 

ag2560

Well-Known Member
Joined
Mar 14, 2010
Messages
403
Reaction score
3
I would replace the timing chain too.
 
  • Like
Reactions: YFM

YFM

Administrator
Staff member
Admin
Moderator
Joined
Dec 8, 2018
Messages
209
Reaction score
15
After further inspection you were right. The intake valve is bent and has a gap you can see light through. I thought I set the timing right but I remember I had to choose be between one tooth or the other when putting timing chain back on. It didn’t seem to line up exactly. Any advice after I replace valves and put it back together. Thank you
Hope it works this time. Good luck!
 
Top